Xfree 4.x + DRI + glide (Voodoo)

Javier Campos

6 de septiembre de 2001

Paquetes necesarios:
* kernel 2.4.x
* libglide3
* xlibmesa3
* xlibosmesa3
* xserver-xfree86
* ...y por supuesto todas las dependencias.
Configuración necesaria en /etc/X11/XF86Config:
* Section "Modules"
* ...
* Load "dri"
* Load "glx"
* ...
* EndSection
# Con esta opción podemos utilizar la aceleración de la tarjeta para
# cualquier usuario.
* Section "DRI"
* Mode 0666
* EndSection
# se ha notificado un bug en el que no se actualiza estos cambios, si en
# modo usuario y después de verificar la configuración no se resuelve se
# recomienda borrar el directorio /dev/dri. Se regenerará.
En el apartado de configuración, sólo recordar que la acceleración de
las versiones Voodoo 3 y anteriores sólo funcionarán si tenemos una
profundidad de 16 bits. ( Depth 16 en la sección "Display").
Verificación :
- Una vez iniciado el servidor X. cat /proc/modules. Verificar si el
módulo tdfx está cargado en Memoria.
- glxinfo debe informar sobre la activación DRI.
Observar si figura esto (correcto):
* OpenGL renderer string: Mesa DRI Voodoo3 20010501 x86/MMX
* OpenGL version string: 1.2 Mesa 3.4.2
En el caso de que sea algo como esto (fallo):
* OpenGL renderer string: Direct Rendering Indirect
Teneis un problema con algunas de las librerias. Probar las
dependencias con ldd en /usr/lib/libGL.so
/usr/X11R6/lib/modules/dri/tdfx_dri.so si existe algún error os
ayudará.
Suerte y a quakear.



Página creada en: 2004-11-04 11:41:01 +0000
© Copyright 2001, 2002, 2003, 2004, La Espiral, debian-laespiral@lists.debian.org
Permitida la copia y distribución textual, integral, siempre y cuando se mantenga este aviso.